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2.1 Installation

· Requirements 
· Install the software 
· Uninstall the software 
· Activate the software
2.1.1 Requirements

·  Pentium-Class processor 

·  Windows 98 Second Edition, ME, NT 4.0, 2000, XP, Vista, 7  

·  256 MB of RAM 

·  20 MB of available hard disk space
2.1.2 Before You Install

Have your Registration Information handy. You need these items to perform an installation and activation.
· Exit any existing copies of the software that you have running. 

· Get administrator privileges on your computer. 

· Consider disabling virus-checking software and Internet security applications on your system for the duration of the installation process. These applications can slow down the installation process or cause it to appear unresponsive (or to hang).
2.1.3 Install the software

· Insert the CD/DVD into the CD/DVD drive connected to your system or double-click the installer file you downloaded from the InforDesk Web site. The software installer starts, displaying the welcome dialog box; click Next 

· Review the software licensing agreement and, if you agree with the terms, select Yes and click Next. 

· In the Installation Type dialog box, specify whether you want to perform a Typical or Custom installation and click Next. 

· Specify the name of the folder where you want to install the software. You can accept the default installation folder or specify the name of a different installation folder. If the folder doesn't exist, the installer creates it.
When specifying a folder name, do not specify a name that contains the @ sign, an exclamation point (!), the per cent character (%), the plus sign (+), or the dollar sign ($) character. The full path of the installation folder must not include a folder named private. To continue with the installation, click Next. 

· When the software installer finishes, it displays the Installation Complete dialog box.
Note: If you want to install the software on a different computer, you must first Uninstall the software on your computer then install the software on new computer and activate it using your license information.
2.1.4 After You Install

To start the software, you can use any of these methods:
· From the Desktop Double-click the ParmisPDF icon (called a shortcut) that the installer creates on your desktop. 

· From the Start menu Click the Start button, select Programs, and move the pointer over the ParmisPDF entry. On the application menu that appears, click the ParmisPDF entry. 

· Using Windows Explorer Navigate to your installation folder of the software. Expand the software folder and then double-click the shortcut to the ParmisPDF executable.

2.1.5 Activate the software

Purchasing the software and then entering the license key you receive will return the product to a fully-functional state.
1. If the Activation dialog box isn't already open, choose Help > Registration. 
2. Enter your registration information in fields. 

3. Click on Register button.
Note: If you want to install the software on a different computer, you must first Uninstall the software on your computer.
2.1.6 Uninstall the software

To remove InforDesk products from your system, follow this procedure:
1. Shut down the software. 
2. Start the uninstaller.
On the Windows Start menu, select Settings>Control Panel>Add or Remove Programs. Select ParmisPDF from the list. 

3. Then continue to uninstall.
3. Convert to PDF/Create PDF

Convert your files including image, text, webpage and RTF to PDF documents and create PDF by combining PDF files.
· From Files 
· Blank PDF
3.1 Convert files to PDF

You can create a PDF document by converting and merging a number of a images or by combining PDF files. For example you have scanned a number of documents (Such as your catalogs) and you want to create a PDF file contains scanned images; you can easily do this using this function. 
To create a PDF file from image files:
Convert to PDF/Create PDF tab>From Files Button 
· Click File Formats button to filter types of files in conversion process 

· Create a list of files. (Drag and drop)  

· Select Page Size of images in Page Size (For Image Files) box 

· Set Output options: 

· Select Create separate PDF files to create a separate PDF file for each input file 

· Select output folder (Leave empty to create files in their original folders)

· Select Merge all to a PDF file to create a single PDF files from selected files

· Check Delete original files to delete original files after converting them to PDF 

· Click Create PDF.
You can easily create PDF files without running ParmisPDF from anywhere in windows environment simply by selecting files, right click, and clicking on Covert to PDF with ParmisPDF (In context menu)
To add (combine) one or more PDF files to a PDF document simply select PDF files then drag and drop file(s) on the PDF file.
 
3.2 Create Blank PDF

You can create a Blank PDF file.
To create a Blank PDF document:

Convert to PDF/Create PDF tab>Blank PDF Button 

· Set properties. 

· Click OK. 

· Select a path and choose a name. 

· Click Save.
4. Watermark/Stamp

Use Watermark to insert image, text (Including dynamic texts such a date, time, file name and much more.), header & footer, background, bates numbering (bates stamping) to PDF documents.

· Watermark: Header, Footer, Text & Image (As background or foreground) 

· Bates Numbering 
· File Attachment
4.1 Watermark

A watermark appears foreground or background of page's contents. The watermark can be an image or as simple as a solid color. You can selectively apply a watermark to only specific pages or page ranges in a PDF.
You can customize the content, appearance and action of each watermark. This includes Position, Alpha Blending, Stroke, Text formatting. You can also preview watermark before applying them.
You can define and save your watermarks to reuse them later, or you can simply apply a watermark and forget it. You can also preview watermarks before applying them and adjust properties like position, color and etc.
To add a Watermark to a PDF document:
· Watermark/Stamp tab>Watermark Button 

· Select file 

· Set Watermark settings; In addition you can Load/Save profiles. 

· Click OK
4.2 Bates Numbering

Bates Numbering (stamping) is the process of placing Bates Numbers on a page. Many companies are still using Bates machines to stamp their documents, a time-consuming, labor-intensive process. Bates Numbering is a method of indexing documents for easy identification and retrieval. ParmisPDF allows users to apply Bates numbers to one document or to a whole set* of documents, and they may apply more than one Bates Numbering sequence to a single or multiple documents. Document sets may also be given a unique set of numbers or prefixes which might include text such as a set number, case number, or firm name. 
ParmisPDF bates numbering tool creates custom bates stamps and you can control every aspect of the stamp's creation: the font and color, the background color, the stamp increments, the stamp placement and many others. This flexible structure allows for accommodation of a wide variety of stamping specifications. You can add unlimited number of stamps per page and there is no limitation in number of stamp elements including static texts(suffix, prefix and etc), dynamic texts (variables like total page/bates, document pages/bates, page number, date/time and etc).
To add a Bates Numbering to PDF documents:
· Watermark/Stamp tab>Watermark Button 

· Select file 

· Horizontal/Vertical Posstion: You can position bates stamp anywhere on the pages. 

· Page Range: Allows you to select the desired stamping page Interval.This means that the bates stamp will appear only on selected pages:  

· Set bates numbering settings in Text tab: 

· In Contents tab, set bates numbering elements including static texts as suffix or prefix and variables (dynamic texts). 

· In Attribute tab, set text contents properties like font, color, angle, stroke and character/word/line spacing. 

· In Background tab, you to select a desired color/pattern for the bates stamp background and set border and curve (rounded corner) for background. 

· In Bates Numbering (Stamping) Options tab, set bates numbering settings: 

· Style: numeric, alphabetical, Roman numerals and etc. 

· Minimum digits of bates stamp: You can set minimum length for Numeric and Alphabetical styles. 

· Start from: defines the starting value. 

· Increment: 

· Value: sets value of element increament on each occurrence. 

· Every ... Page(s)/Document(s): Defines when the increment counter should occur. For example, if the Increment Every is set to 3 Page(s), the increment will occur every 3 pages.

· Load/Save profiles: After you have set properties, you might need it in the future; with Load/Save profiles you can store and re-use or continue working on it later. 

· Click OK
*Use Batch Operation or Command Line to apply Bates numbers to a whole set of documents
4.3 Stamp

  

You apply a stamp to a PDF document in much the same way you apply a rubber stamp to a paper document. You can choose from a list of predefined stamps such as APPROVED, DRAFT, CONFIDENTIAL and etc, design a custom stamp (even dynamic stamps) or use your own stamps.
To add a Stamp to a PDF document:
Watermark/Stamp tab>Stamp Button 
· Select file 
· Select predefined stamps in Buildt-in Stamps tab; if you need a custom and dynamic stamp select Dynamic/Custom Stamp tab and click Design Stamp button; Also you can insert a stamp from a file by selecting Image Stamp tab and Click Select Image button. 
· Set Stamp size (Width and height) 

· Set Appearance settings 
· Enter Author, Subject and Comment for your stamp 
· Set size, position of stamp 
· Select range of stamp 
· Click OK
4.3.1 Dynamic/Custom Stamp

  

You can easily design your own custom stamp based your needs. You custom designed have the same characteristics as predefined stamps; each includes a pop-up note and editable properties.
To Design and insert a Dynamic/Custom Stamp:
Watermark/Stamp tab>Stamp Button>Click Dynamic/Custom Stamp tab>Design Stamp Button
· In "Text 1" and "Text 2" box 

· Enter your text in Text Field. 

· Select Variables from drop down-menu. These variables are dynamic. For example you can have date and time in your stamp dynamically. 

· Adjust position of text in your stamp by specifying distance from top and left of stamp 

· Select font properties by clicking Font button
· In "Text 1" and "Text 2" box

· Specify stamp properties such size, angle, border size, border color, fill style, fill color and corner curve.

· If you want to re-use this stamp Click "Save As..."

· Click OK
Note: You can see a live preview of your design in "Image Preview" box.
4.3.2 Image Stamp
You can use your own stamps for stamping documents. The stamps which you import from a file have the same characteristics as predefined stamps; each includes a pop-up note and editable properties.
To insert a Image Stamp:
Watermark/Stamp tab>Stamp Button>Select Image Stamp tab>Select Image
· Click OK
Note: You can see a live preview of your design in "Image Preview" box.
4.3.3 Built-in Stamp
You can choose from a list of predefined stamps such as APPROVED, DRAFT, CONFIDENTIAL and etc.
· To insert a predefined stamp:

Watermark/Stamp tab>Stamp Button>Select Built-in Stamp tab>Select Image

· Click OK
Note: You can see a live preview of your design in "Image Preview" box.

5. Security
You use security features (Permissions/Restrictions, Password, Encryption & Digital Sign) to lock a PDF just as you lock doors of your home to prevent others to enter without your permissions. For example, you can use passwords to restrict users from opening, printing, and editing PDFs. You can encrypt PDFs with different methods. If you want to save security settings for later use, you can Save your security profile.
· Set Permissions 

· Digital Sign
5.1 Set Permissions
You can use passwords to apply different kind of restrict for users such as opening, printing, editing, extracting and etc. You can encrypt PDFs with different methods. If you want to save security settings for later use, you can Save your security profile.
To Set Security for a PDF document:
Security tab>Set Permissions Button 
· Select file 

· Set Security settings; In addition you can Load/Save profiles. 

· Click OK
5.2 Digital Sign (Signature)
You can digitally sign a PDF to indicate your approval. A PDF can be signed more than once and by more than one person. When you sign a document, your digital signature appears in the signature field. The appearance of the signature depends on options you choose. 
To Digital Sign a PDF document:
Security tab>Digital Sign Button 
· Select file. 

· Select Digital ID file. 

· Set signature settings and type; In addition you can Load/Save profiles. 

· Click OK.

6. Page Manipulation
You can apply various types of operations on your PDF documents' pages such as:

· Merge Pages 

· Insert Pages 

· Delete Pages 

· Rotate Pages
6.1 Insert Pages
You can insert pages of a PDF document to another PDF document.
To Insert Pages:
Page Manipulation tab>Insert Pages Button 
· Select file. 

· Select the file which you want to insert; In addition you can Load/Save profiles. 

· Set location for inserting pages of selected PDF document. 

· Click OK
6.2 Delete Pages
You can delete page or a range of pages of a PDF document. You can specify pages which you want to delete such: first pages, last page, odd pages, even pages, range of pages and etc.
To Delete Pages:
Page Manipulation tab>Delete Pages Button
· Select file. 

· Select range of pages; In addition you can Load/Save profiles. 

· Click OK
6.3 Rotate Pages
You can rotate all or selected range of pages in a PDF document. Rotation is based on 90� increments.
To Rotate Pages:
Page Manipulation tab>Rotate Pages Button
· Select file. 

· Select direction of rotation.

· Select range of pages; In addition you can Load/Save profiles. 

· Click OK.

7. Extract
Extraction is the process of creating a new PDF document contains pages of another PDF document, or saving contains of a PDF documents in TXT file, or taking our and saving file attachment of a PDF document. Extracted pages contain not only the content but also all form fields, comments, and links associated with the original page content.

Note: The creator of a PDF document can set the security to prevent the extraction of pages. So before extraction check Security permissions of PDF document

· Pages 

· Text 

· Attachments
7.1 Extract Pages
Extraction is the process of creating a new PDF document contains pages of another PDF document. Extracted pages contain not only the content but also all form fields, comments, and links associated with the original page content.
To Extract Pages:
Extract tab>Pages Button 
· Select file 

· Select range of pages; In addition you can Load/Save profiles. 

· Click OK. 

· Select a path and choose a name for Extracted PDF document. 

· Click Save.

Note: If you want to save each page in separate PDF files mark this check box: Extract Pages as Separate Files.
7.2 Extract Text
Extraction is the process of creating a new PDF document contains pages of another PDF document. Extracted pages contain not only the content but also all form fields, comments, and links associated with the original page content.
To Extract Text:
Extract tab>Text Button 
· Select file 

· Select range of pages; In addition you can Load/Save profiles. 

· Click OK. 

· Select a path and choose a name for Text files contains extracted PDF document. 

· Click Save.

Note: If you want to save each page in separate TXT files mark this check box: Extract Pages as Separate Files.
7.3 Extract Attachments
To Extract Attachments:
Extract tab>Attachments Button 
· Select file 

· Select attachment and write attachment description; In addition you can Load/Save profiles. 

· Click OK.
Note: Attachment will be extracted in a folder named "FILENAME.pdf_Files" where your PDF file located.
8. JavaScript
The JavaScript language was developed as a means to create interactive web pages more easily. Although best known for its use in websites (as client-side JavaScript), JavaScript is also used to enable scripting access to objects embedded in other applications.
You can easily integrate this level of interactivity into your PDF documents.
The most common uses for JavaScript in forms are formatting data, calculating data, validating data, and assigning an action.
In order to gain programming knowledge in JavaScript, you need to review sources you can find on the internet and books on JavaScript from local and online book resellers.
· Add Action 

· Remove Action 

· Add
8.1 Add Action
You can cause an action to occur when document opened, page is viewed, and bookmark or link is clicked. For example you can use links and bookmarks to jump to different page in a document, execute commands from a menu, show a message, and perform other actions.
To Add Action:
JavaScript tab>Add Action Button 
· Select file 

· Enter JavaScript code in JavaScript box. 

· Specify when you want the action to be executed; In addition you can Load/Save profiles. 

· Click OK. 

Note: If you want to existing actions of a document mark this check box: Remove existing actions.
8.2 Remove Action
You can remove existing actions in a PDF document.
To Remove Action:
JavaScript tab>Remove Action Button 
· Select file

8.3 Add
To Add JavaScript: 
JavaScript tab>Add Button 
· Select file 

· Select attachment and write attachment description; In addition you can Load/Save profiles. 

· Click OK
9. Document
You can apply various types of operations on your PDF documents such as:
· Set Information 

· Numbering 

· Find/Replace 

· Clean Up 

· Compression
9.1 Numbering
You can insert numbering for your PDF document. You can set various types of numbering styles and set numbering options.
To add Numbering to a PDF document:
Document tab>Numbering Button 
· Select file 

· Set numbering style and options; In addition you can Load/Save profiles. 

· Click OK
9.2 Clean Up
You can clean Up a PDF document by removing various objects such as text annotations, 3D annotations, Stamps, Files, JavaScripts, Bookmarks and etc.
To Clean Up a PDF document:
Document tab>Clean Up Button 
· Select file 

· Mark objects which you want to be deleted; In addition you can Load/Save profiles. 

· Click OK. 

· Select a path and choose a name for saving cleaned up PDF document. 

· Click Save.

9.3 Set Information
You can set document information such title, author, subject, keyword and company.
To Set Information for a PDF document:
Document tab>Set Information Button 
· Select file 

· Enter information in fields; In addition you can Load/Save profiles. 

· Click OK
9.4 Attach File
You can attach PDFs and other types of files to a PDF. If you move the PDF to a new location, the attachments move with it. 
To add a File Attachment to a PDF document:
Add/Insert tab>File Attachment Button 
· Select file 

· Select attachment and write attachment description; In addition you can Load/Save profiles. 

· Click OK
Important: Some application won�t open certain file formats (such as EXE, VBS, or ZIP), because the format is associated with malicious programs, macros, and viruses that can damage computers.
9.5 Find/Replace
You can easily find text in PDF document and replace it with another text. For example you can easily change your phone number or E-mail address in a PDF document.
To Find/Replace a text in a PDF document:
Document tab>Find/Replace Button 
· Select file 

· Enter text to find and enter text which you want to replace; In addition you can Load/Save profiles. 

· Click OK. 

· Select a path and choose a name for saving modified PDF document. 

· Click Save.

9.6 Compression
You can compress PDF file and reduce the actual size of PDF document.
ParmisPDF allows you to shrink PDF file by using ZIP (Flate) or Image compression. 
To set Compression settings:
Menu>Options>Settings... 
· Select ZIP (Flate) Compression Level: To specify compression level of contents and also images which you would like to be compressed with ZIP (Flate) method 

· Select Image Compression type and quality 

· Click OK
10. Flatten
You can use Flatten function if you are supposed the form fields or annotations in your documents not to be altered.
· Flatten Forms 

· Flatten Annotations
10.1 Flatten Forms
Flattening Form is process of removing form-field code from a PDF file after a form field has been populated with text or graphics. If the a PDF document contains form fields, contents of fields can be easily altered and edited so it's a good thing if you want allow others to edit fields in your PDF documents.
To Flatten Forms:
Flatten tab>Forms Button 
Note:  It may be a good idea to save an un-flattened copy of the document if there is a chance that changes will need to be made to these annotations later.
10.2 Flatten Annotations
After annotations have been flattened, they will lose all their interactivity and other special features and will become static graphics. That's a good thing to flatten your PDF documents If you are supposed the annotations in your documents not to be altered. (For example by other people if you want distribute it)
To Flatten Annotations:
Flatten tab>Annotations Button 
Note:  It may be a good idea to save an un-flattened copy of the document if there is a chance that changes will need to be made to these form fields later.
 
11. Find/Replace
This enables you to look for search terms in multiple PDFs. In addition you can simply delete or replace it with other text. For example, you can search across all PDFs in a specific location, or you can simply change your company website or email using this function.
· Find 

· Page Count
11.1 Find
This enables you to look for search terms in multiple PDFs and and delete/replace it with another text or an image file.
You can search for PDF documents by name or containing text.
To Find a PDF document:
Find / Replace Button 
· Fill "File Name" Field. Wildcards are accepted (For example Book*.pdf). 

· Select "Input Folder". 

· Fill "Text to Find"; if you are looking for PDF documents which contains this text. 

· Click Replace With radio button and fill Replace by Text field (If you leave this field empty searched term will be deleted. 

· Select "Output Folder". 

· If you want to insert an image in place of "Text to Find", Mark "Insert image in text place" and set properties 

· Click Execute.

Note: If documents are encrypted (have security applied to them), you cannot search them.
11.2 Page Count
This enables you to easily count total number of pages for selected PDF documents. This function is ideal for imaging bureaus where and accurate page count of PDF files is essential to prepared estimation of work.
To count number of pages:
Find / Replace Button 
· Select the path of folder which contains PDF files that you want to count number of pages. Mark "Include files in subfolders" if you want files into subfolders to be selected. 

· Leave "File Name" and "Containing Text" fields empty; If you want to count pages contain specific text simply enter text in "Containing Text" field; If you want to count pages of files with specific name enter text in "File Name" field (Wildcard is accepted. For example *Book*). 

· Click Find. 

· In bottom of window you can see total number of files and pages.

12. Batch Operation
When you want to apply a number of routine sets of commands to your PDF files, you can save time and keystrokes by using an automated batch sequence.
Batch sequence is a defined series of commands with specific settings and in a specific order that you apply in a single step.
12.1 Create a New Batch Sequence
To create a new batch sequence:
· Batch / Command Line button

Click New.... 

· Type a descriptive name for your Batch Sequence in the dialog box and click OK. 

· Click Edit. 

· Click OK.

Edit Batch Sequence
12.2 Edit Batch Sequence
To select, edit and configure commands settings:
Edit>Commands tab>Commands Button
· Click commands in left side box 

· Click Add button 

· Click Edit button to configure setting for selected command. Edit button is disabled for commands which have not configurable settings; Such as Remove Security. 

· Click Move Up and Move Down button to change order of commands 

· Click Remove to remove commands from right side box (your Batch Sequence) you can unmark command(s) in right side box. Unmarked commands with their configured settings will remain in your Batch Sequence but they won't run until you mark them.

Note: In Commands list box you can see list of commands in your Batch Sequence.


To select input files:
Edit>Click Input tab>Click Files/Folders tab
· Drag/Drop Files/Folder 



To Process files in subfolders:
Edit>Click Input tab>Click Options tab
· Mark Process Files in Subfolders During Batch/Command Line Operation check box



To select Input File Types:
Edit>Click Input tab>Click Options tab
· Select files types in File Types box



To select Blank PDF as Input:
Edit>Click Input tab>Click Options tab
  Mark Create a Blank PDF as Input File at Batch Operation Runtime check box 

  Click Set Blank PDF Properties button to set Blank PDF properties. 

  Set Blank PDF Name and Location 

  Click OK. 

Note: If you select Folder as input, all files into the folder will be selected; If you add files into the folder they would be in your list too; But If you select List of Files only selected individual files or selected files into folders would be in your list.



To define output location:

  Edit>Select Output tab
To overwrite output files on your input files:
· Click Same as Original Folder(s) radio button.

To save output files to specified folder:
· Click Specified Folder radio button. 

· Select output folder.



To set files naming method for output files:
Edit>Output File Naming tab
If you want to name output files same as original files:
· Click Same as Original(s) radio button.

If you want to name output files by adding a suffix or prefix to original files:
· Click Add to Original Base Name(s) radio button. 

· Enter Prefix and Suffix in fields

12.3 Run Batch Sequence
To Run a Batch Sequence: 
Batch / Command Line Button
Select Batch Sequence from Batch Sequences List. 
· Click Run
